YctaHoBka Wing Personal (Ha npumepe Bepcuu 7.2.6) Ha KoMnblOoTEP
nop, ynpasneHuem onepaumnoHHon cucrtembl Windows
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B nosiBuBLLIEMCS cnucke BblbpaTb CCbINKy nepexoga Ha canT https://wingware.com/

&« > C 8 google.ru/search?newwindow=18tsxsrf=ALeKk02PIn7Wx1GU61Col5fuuV6MCaZdtQ%3A1604298723860&source=hp8&iei=46efX6mLMuj0gwHPolJA&q=... ¥ [§ (M “1 :

Go gle wing X = & Q a5 “,

Hanucano Ha: Python, Cython, Cu, C++

[Moxoxwe 3an pocChI

wingware com v epeBecTu 3Ty CTpaHuuy y D @ I h

SPYDER
Wing Python IDE - D€ igned for Python PyCharm PyDev Spyder Thonny PyScripter

Pymon IDE with intelligent editor, powerful debugger, remote development error
checking, refactoring, and much more. Wing was designed from .
Bbl noceLyanu 3Ty CTpaHuLy HECKONbKO pas. [lata nocnefHero noceweHns: 27.10.20

CooGwuTs 0 npodneme

B03MOXHO, Bbl MCKanu

Downloads Wing Personal

Wing Pro. The full-featured Python Wing Personal - Version 7.2.6 - Kpbino N

IDE for professional developers . Released 2020-10-07. Wing ... Kpbino - 370 TUN NnasHUKa, KOTOPbIH Co3AaeT
NOABLEMHYI0 CUNY NPU ABIWKEHUM

Wing 101 Wing Pro

Wing 101 - Version 7.2.6 - Wing Pro - Version 7.2.6 -

Released 2020-10-07. Wing Released 2020-10-07. The

Opyrue pesynsTaTbl C caiTa wingware.com »

context.reverso.net » nepesof > wing v

wing - [NepeBoa Ha pyccKuii - NpUMepbl aHmMuitcknin | Reverso ...
Mom said you'd take me under your wing. YBuaumca. Mama ckasana, 4To Tbl BO3bMELLb MEHA

noa CBOE Kpbino.
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[lepenTtn Ha canT wingware.com

@ wing - lMowmck & Google X

& wingware.com

WIN

THE INTELLIGENT DEVELOPMENT ENVIRONMENT FOR PYTHON

Wing Python IDE was designed from the ground up
for Python, to bring you a more productive

development experience.

TRY WING PRO

Current version: 7.2.6 | Early access: 8.0.0.0 (alpha)

Get More Done

Type less and let Wing worry
about the details. Get immediate
feedback by writing your Python
code interactively in the live
runtime. Easily navigate code and
documentation.

! Wing Python IDE - Designed for X

About Download Pricing Contact Q

PYTHON ‘,
IDE

"Thank you for making the
best Python IDE available.”
Clinton De Young

"The debugger just works,
and it works well.”
Joshua J. Kugler

Testimonials & Reviews
Why Wing Pro?

ekt 7y b 3.k Se-TCumpr Ny
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[MepenTn B pasgen Downloads -> Wing Personal

&« - C & wingwarecom * (1« B ON@

G Wingware About Download Support

WIN G fzren

THE INTELLIGENT DEVELOPMENT ENVIRONMENT FOR PYTHON

Contact Q

"Thank you for making the
best Python IDE available.”

Wing Python IDE was designed from the ground up Clinton De Young

for Python, to bring you a more productive
development experience.

Current version: 7.2.6 | Early access: 8.0.0.0 (alpha)

"The debugger just works,
and it works well.”
Joshua J. Kugler

Testimonials & Reviews
Why Wing Pro?

) ey e
Get More Done EwlEB i x & h * N> m N3P o ME-IIWA § ©

7 ARunTests * Filter. remote

Project: ide-7,05vpr (5323 files 4 437 dirs} .1 Options
mainkeon. py
memprofile py
oprutils <

Type less and let Wing worry
about the details. Get immediate
feedback by writing your Python
code interactively in the live
runtime. Easily navigate code and
documentation.

* at_addons.py

Testing »Exceptions Breakpoints  Search  Mercurial,  Python Shell | Debug Probe  0S (

€l * remoteops.py CProxy _getatuibute wrap A=vX -
10:56
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[lanbHenwmne 0encTemns onuceiBaroTCcs Ha npumepe Bepcun Wing Personal 7.2.6 ans Windows

@ wing - Mowck & Google X . Download Wing Personal v. 7.26 X ¢

& > C & wingware.com/downloads/wing-personal * Yt O » @

m Wingware About Download Support Pricing Contact Q

WIN G fzHen

THE INTELLIGENT DEVELOPMENT ENVIRONMENT FOR PYTHON

Wing Personal - Version 7.2.6 - Released 2020-10-07 Download Wing Personal:

Wing Personal is a free Python IDE designed for students and hobbyists. It omits many features
found in Wing Pro. Compare Products

Windows Installer

32-bit and 64-bit

Wing Personal is free to use for any purpose and does not require a license to run.
SHAT: c232abfde132ea430f88b359ec79044178be7154

Tutorial
\C/z;::ck‘ S’:art Guide Windows Zip File
at's New 32-bit and 64-bit

SHA1: 888452a79f38095734ccf544520583886 1ee74fb

Other OSes: 0S X Linux 64-bit

i " Supported OSes
Other Versions: 8.0.0.0-alpha 7.1.3 7.0.4 6.1.5 5.1.12 4.1.14 3.2.13 all versions 3
Supported Python Versions

Change Log

Other Products: Wing Pro Wing 101 — Compare Product Features

Quickstart HTM

=

US Letter

Tutorial HTML  US Letter
HTML  US Letter

i<
O N N

Manual




HaxkaTtb kHonky Windows Installer 1 ckadaTb yCTaHOBOYHLIN (hann

@ wing - Mowck & Google X . Download Wing Personal v. 7.26 X f

& > C & wingware.com/downloads/wing-personal * (Yt O » @ :

m Wingware About Download Support Pricing Contact Q

WIN G fBzHen

THE INTELLIGENT DEVELOPMENT ENVIRONMENT FOR PYTHON

Wing Personal - Version 7.2.6 - Released 2020-10-07 Download Wing Personal:

Wing Personal is a free Python IDE designed for students and hobbyists. It omits many features
found in Wing Pro. Compare Products

Windows Installer

32-bit and 64-bit

Wing Personal is free to use for any purpose and does not require a license to run.
SHAT: c232abfde132ea430f88b359ec79044178be7154

Tutorial
\C/z;::ck‘ S’:art Guide Windows Zip File
at's New 32-bit and 64-bit

SHA1: 888452a79f38095724ccf544520583886 1ee74fb

Other OSes: 0S X Linux 64-bit

i " Supported OSes
Other Versions: 8.0.0.0-alpha 7.1.3 7.0.4 6.1.5 5.1.12 4.1.14 3.2.13 all versions 3
Supported Python Versions

g ; Change Log
Other Products: Wing Pro Wing 101 — Compare Product Features
Quickstart HTML US Letter A4
Tutorial HTML  US Letter A
Manual HTML  US Letter A4 b
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[loxxnaTbCca OKOHYaHMA 3arpy3km yCTaHOBOYHOIO doanna wing-personal-7.2.6.0.exe

@ wing - lMouck & Google @ Wing Python IDE - Designed for X

CSae il ) & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe ¥ (¥ t (M “y

m Wingware About Download Support Pricing Contact Q

W IN G RyzHen

THE INTELLIGENT DEVELOPMENT ENVIRONMENT FOR PYTHON

Thanks for Downloading Wing!

Wing Pro is a full-featured Python IDE for professional
developers. A free 30-day trial divided into three 10-day
periods can be activated when Wing Pro is launched.

Get Helpful Hints

Subscribe to receive tips, tricks, and helpful hints for Wing about
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

wing-personal-7.2.....exe

Mokazatb Bce X
3,1/55.7 MB, Ocranace 1 sk,

11:04
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[Tocne oKoH4YaHus 3arpy3kn 3anyCTUTb YCTAaHOBOYHbLIN (pains wing-personal-7.2.6.0.exe

@ wing - lMowmck & Google

@ Wing Python IDE - Designed for X

CSae il ) & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe ¥ (¥ t (M “y

m Wingware About Download Support Pricing Contact Q

W IN G RyzHen

THE INTELLIGENT DEVELOPMENT ENVIRONMENT FOR PYTHON

Thanks for Downloading Wing!

Wing Pro is a full-featured Python IDE for professional
developers. A free 30-day trial divided into three 10-day
periods can be activated when Wing Pro is launched.

Get Helpful Hints

Subscribe to receive tips, tricks, and helpful hints for Wing about
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

8 wing-personal-7.2....exe

= o ® 3 F e @&« B ® T - 9 ™ A @) ey T8

02.11.2020 EZ
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HaxaTb KHOMKY Next 1 Ha4aTb YCTaHOBKY NakeTa nporpamMmm

CSae il ) & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe

|

e B o » ¢ ¢

About Download Support Pricing Contact Q

WI N DyvTiLimiai
- X

Welcome to the Wing Personal 7.2
Setup Wizard

m Wingware

THE INTELLIGENT DEVELOPME

This will install Wing Personal 7.2.6.0 on your computer.

Itis recommended that you dose all other applications before
continuing.

Click Next to continue, or Cancel to exit Setup.

Thanks for Downloading

Wing Pro is a full-featured Python IDE
developers. A free 30-day trial dividg
periods can be activated when Wing

Get Helpful Hints

Subscribe to receive tips, tricks, and he
once per week:

C=o ) e
>

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:

11:13
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BuibpaTh | accept the agreement 1 HaXkaTb KHOMKY Next

@ Wing Python IDE - Designed for X / /

< 95C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe

m Wingware About

DyvTiimni
5 Setup - Wing Personal 7.2 = X
License Agreement

Please read the following important information before continuing.

THE INTELLIGENT DEVELOPME

Please read the following License Agreement. You must accept the terms of this
agreement before continuing with the installation.

This End User License Agreement (EULA) is a CONTRACT between you (either ~
an individual or a single entity) and Wingware, which covers your use of
. “Wing Pro” and related software components. All such software is referred

Tha n kS for Down load] n g \ to herein as the "Software Product.” A software license and a license
key or serial number ("Software Product License”), issued to a designated
user, only by Wingware or its authorized agents, is required for each user
Wing Pro is a full-featured Python IDE of the Software Product. If you do not agree to the terms of this EULA,

s e then do not install or use the Software Product or the Software Product
developers. A free 30-day trial dividg License. By using this software you acknowledge and agree to be bound by

periods can be activated when Wing P the folawing terms:

@ I accept the agreement

Get Helpful Hints

(D1 do not accept the agreement

Subscribe to receive tips, tricks, and hg.
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:

11:15
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HaxkaTb KHOMKy Next

&« > C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe w (¥ t QN “y :

m Wingware About Download Support Pricing Contact Q =

DyvTiimni
ﬁ Setup - Wing Personal 7.2 -
Select Destination Location

Where should Wing Personal 7.2 be installed?

THE INTELLIGENT DEVELOPME

Setup will install Wing Personal 7.2 into the following folder.

To continue, dick Next. If you would like to select a different folder, dlick Browse.

Thanks for Downloading \ Browse...

Wing Pro is a full-featured Python IDE
developers. A free 30-day trial dividg
periods can be activated when Wing P

Get HEIPfUl Hints Atleast 151,5 MB of free disk space is required.

Subscribe to receive tips, tricks, and hg.
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:
11:20
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HaxkaTb KHOMKy Next

&« > C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe w (¥ t QN “y :

m Wingware About Download Support Pricing Contact Q =

DyvTiimni
ﬁ Setup - Wing Personal 7.2 -
Select Start Menu Folder

Where should Setup place the program's shortcuts?

THE INTELLIGENT DEVELOPME

Setup will create the program'’s shortcuts in the following Start Menu folder.

To continue, dick Next. If you would like to select a different folder, dlick Browse.

Thanks for Downloading \ Browse..

Wing Pro is a full-featured Python IDE
developers. A free 30-day trial dividg
periods can be activated when Wing P

Get Helpful Hints

Subscribe to receive tips, tricks, and hg.
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:
11:26
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HaxkaTtb KHOrKy Install

—
< 95C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe w (¥ t (M “y :
m Wingware About Download Support Pricing Contact Q =
DvTiiam N
5 Setup - Wing Personal 7.2 = X
Ready to Install
Setup is now ready to begin installing Wing Personal 7.2 on your computer.
THE INTELLIGENT DEVELOPME

Click Install to continue with the installation, or dlick Back if you want to review or
change any settings.

Destination location:
C:\Program Files (x86)\Wing Personal 7.2

Thanks for Downloading | |startmenu focer:

Wing Personal 7.2

Wing Pro is a full-featured Python IDE
developers. A free 30-day trial dividg
periods can be activated when Wing P

Get Helpful Hints

Subscribe to receive tips, tricks, and hg.
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:
11:31
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[loxxaaTbCca OKOHYaHUS YCTaHOBKH

@ Wing Python IDE - Designed for X /

ey 7 |
< 95C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe

m Wingware About Download Support Pricing Contact Q =

DyvTiimni
5 Setup - Wing Personal 7.2 = X
Installing H
Please wait while Setup installs Wing Personal 7.2 on your computer.
THE INTELLIGENT DEVELOPME

Extracting files...
C:\...\bin\__os__\win32\untime-python2.7\Lib\encodings\euc_jisx0213.py

Thanks for Downloading \

Wing Pro is a full-featured Python IDE
developers. A free 30-day trial dividg
periods can be activated when Wing P

Get Helpful Hints

Subscribe to receive tips, tricks, and hg.

once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:

11:33
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[10 OKOHYaHMKM YCTAaHOBKM HaXkaTb KHOMKY Finish. YcTaHOBKa 3aBeplueHa

o

& > C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe Bel Lyt QN wv :

WIN

THE INTELLIGENT DEVELOPME

m Wingware About Download Support Pricing Contact Q

DyvTiLimiai
ﬂj_-.’y‘ Setup - Wing Personal 7.2

Completing the Wing Personal 7.2
Setup Wizard

Setup has finished installing Wing Personal 7.2 on your
computer. The application may be launched by selecting the
installed icons.

Click Finish to exit Setup.

Thanks for Downloading

Wing Pro is a full-featured Python IDE
developers. A free 30-day trial dividg
periods can be activated when Wing

Get Helpful Hints

Subscribe to receive tips, tricks, and he
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:

11:33
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B meHio Windows nogasursics pasgen Wing Personal 7.2 ¢ nporpammon Wing Personal 7.2

CSae il ) & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe

n=~=load Support Pricing

Realtek Audio Console Cospasaiite Wrpaiite

Bca sawa nouyta B ogHoi cryxbe

Stype @ &= @

W mHoroe apyroe...

Spec A
,E = r(y Moura KomnaneoH k...

N |
prime
Telegram Desktop N Vid eo

TreeSize Free

Wccnepyiite
VideoLAN

Hosbie

& o

Microsoft Store Microsoft Edge

WhatsApp Desktop Lenovo

Windows PowerShell O6nauxo

Wi sonal 7.2 A S

. Technical Support Skype
# Wing Personal 7.2

l Wise Care 365 a =

X Solitaire Baw renedoH

Bl Yy Game Rar
11:36
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Mpw XenaHnm MOXHO NepeTalunTb Apnbik Wing Pensonal 7.2 Ha naHenb 3agad

&« > C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe ¥ (¥ t QN “y :

[+ I N~=load Support Pricing Contact

Telegram Desktop R Bca Bawa nouta & oaHoi crykbe

TreeSizeFree © Eh hd| \9

E i W mHoroe apyroe...

Kanetgaps Moura ™ KomnahboH k... . Ootorpadum
. 1 j
prime |/
video
WhatsApp Desktop

Windows PowerShell .
Wccnepyiite

Wing Personal 7.2

Technical Support ﬂ

Wing Personal 7.2

Microsoft Store Microsoft Edge Lenovo

. Wise Care 365 Q6nauro

x y = I @ L

r(: Xbox Game Bar
Solitaire
O al

Angexc.Mysbika | Intel® Graphi...

Besonacrocts Windows

ByawnbHukm v Yace!

& Wing Personal 7.2 11:39
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Tenepb 3anyck Wing Pensonal 7.2 BO3MOXEH 1 Yepe3 prblK Ha naHenu 3agad

@ wing - lMouck & Google @ Wing Python IDE - Designed for X

CSae il ) & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe ¥ (¥ t (M “’

m Wingware About Download Support Pricing Contact Q

W IN G RyzHen

THE INTELLIGENT DEVELOPMENT ENVIRONMENT FOR PYTHON

Thanks for Downloading Wing!

Wing Pro is a full-featured Python IDE for professional
developers. A free 30-day trial divided into three 10-day
periods can be activated when Wing Pro is launched.

Get Helpful Hints

Subscribe to receive tips, tricks, and helpful hints for Wing about
once per week:

Email: ‘ | [subscribe]

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps
To get started, take a look ghuile following
0 O 8 F @ & V4 % @ & - B R A Q) PYC 02.1111:.42;30 =]



[Mpn nepBom 3anycke Wing Pensonal 7.2 Ha)kaTb KHOMKY Accept

Wi IDE - Designed for X
@ Wing Python esigned for / [ ] > N\

< 95C & wingware.com/get&prod=wing-personal&itarget=pub/wing-personal/7.2.6.0/wing-personal-7.2.6.0.exe

s ]

m Wingware About Download Support Pricing Contact Q =

W I N # License Agreement ? X
Wing is licensed software. Its use is subject to the terms and conditions of the following

license agreement:

THE INTELLIGENT DEVELOPME

This End User License Agreement (EULA) is a CONTRACT between you (either an A
individual or a single entity) and Wingware, which covers your use of "Wing Pro" and
related software components. All such software is referred to herein as the "Software
Product.” A software license and a license key or serial number ("Software Product
License"), issued to a designated user, only by Wingware or its authorized agents, is

i required for each user of the Software Product. If you do not agree to the terms of this
Tha n ks for Down load] n g \ EULA, then do not install or use the Software Product or the Software Product License.
By using this software you acknowledge and agree to be bound by the following
Wing Pro is a full-featured Python IDE| |terms:

developers. A free 30-day trial dividg
periods can be activated when Wing A

1. EXPIRING LICENSE WARNING

< £ e v
L Snme Software Product Licenses for this Software Product have an evniration date 7 |

Get Helprl Hints If you accept the terms of this license agreement, press ‘Accept’. Otherwise, press

‘Decline.’
‘D % Decline

Subscribe to receive tips, tricks, and he
once per week:

Email: | | pumscrioe;

You can unsubscribe any time, and your email address is never
used for anything else.

Next Steps

To get started, take a look at the following:

11:45
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[loxxnatbca 3anycka npunoXxeHus, Haxatb File -> New nnu 3arpy3nTb HY>XHbIW oans

# Default Project: Wing - m] X
File Edit Source Project Debug Tools Window Help
Ctrl+N ]lll ® @ =
Ctrl+0 7
©m Project... Ctrl+Shift+0 %‘,
Open from Keyboard Ctrl+K &
Recent 4 o
5
File Sets > £
<
Close Ctrl+W o
Close All 2
@
Close Others
<
Save Ctrl+S 2
Sav Ctrl+Shift+S =
Save All
&
Revert to Disk 2
o
@
Insert File... -
2
Print. Ctrl+P 2
Page Setup... =
20
Quit Ctrl+Q £
5
k-]
1=
SearchinFiles  Search  Stack Data ¥ Debugl/O  Exceptions  Python Shell Messages  OS Commands v
Lookin:‘[Project files V‘Filter:KAII Source Files v} C ds execute without debug. Use arrow keys for history. & =+  Options ~
Search: v
: Python 3.9.0 (tags/v3.9.0:9cf6752, Oct 5 2020, 15:34:40) [MSC v.
Previous Next Pause Options ~ " I s “ o span "y " s
Type “"help"”, “copyright"”, “credits" or "license" for more informa
>>>
< >

11:52
02.11.2020 EZ
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[1na KoppekTHoM paboTbl C KNPUNNULEN HeobxoamMma ycTaHOBKa KOAMPOBKN Unicode
(UTF-8).

HacTponka KoanpoBKM OCYLLIECTBISAETCA B YEThLIPEX MECTaX:

1. Edit -> Preferences -> Debugger -> 1/O -> Debug 1/0 Encoding,

2. Edit -> Preferences -> Debugger -> 1/0 -> Shell Encoding,

3. Edit -> Preferences -> Files -> Default Encoding,

4. Project -> Project Properties... -> Options -> Default File Encoding.

[1py BO3HMKHOBEHUM NMPobnem TpebyeTca BblIbpaTb 3Ha4YeHMe Unicode (UTF-8) utf-8.
[Tocne nameHeHna HacTpoek nepesanyctutb Wing.



[ns yctaHOBKM KOONMPOBKN HaxkaTb Edit -> Preferences... -> Files -> Default Encoding

# untitled-1.py (C:\Users\Nick): Default Project: Wing
File = Edit Source Project Debug Tools

Ba Undo

Helg Redo

< Cut
Copy
Paste
Clear

Copy Filenames

Select
Selection Mode
Multiple Selections

Search and Replace
Mini-search

Goto Line...

Show Line Numbers

Zoom

Start Macro Record

Execute Macro

Reload All Scripts
Command by Name
Sear

onality
Eook Preferences...

Ctrl+Z
Ctrl+Shift+Z

Ctrl+X
Ctrl+C
Ctrl+V

Ctrl+L

Crl+(

Ctri+M

Ctrl+F12

Window Help

v

All Source Files

v

Searchr]

v

Previous Next

" Line1Col 0* [User]

Pause

Options ~

Debug /O Exceptions

No debug process

Python Shell

Messages

0S Commands

F v

Options ~

Call Stack Source Assistant Project

Source Browser

Indentation

Project: Default Project [0 files / 0 dirs]

X
Options ~



BbibpaTtb 3Ha4veHne Unicode (UTF-8) utf-8, HaxkaTb KHOMKy Ok

[ 4

AeEe X

Help  untitled-1.py *

<

LTAE N I

I Ze

@ RB» T

# Preferences

Category

Vv User Interface
Layout
Toolbar
Fonts
Keyboard
Perspectives
Other
Advanced

Vv Projects
Context Menu

v Files
File Types
Reloading

Vv Editor
Selection/Caret
Occurrences
Callouts
Indentation
Line Wrapping

% Factory Defaults

Files: General

2\

Default Directory Policy
Title Style

Default Encoding
New File EOL
New File Extension

Max Recent Items

[ Auto-Save Files Before Debug or Execute
Base on the Current File or Selection v
Append Relative Path v

Show Hostname in Titles
Unicode (UTF-8) utf-8 v
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The default encoding to use for text
files opened in the source editor and

ey

other tools, when an encoding for that

Maximum File Size (MB)

file cannot be determined by reading the
file. Other encodings may also be

tried. This also sets the encoding to

use for newly created files.

Indentation

XK Cancel

v/ Apply

SearchinFiles  Search  Stack Data
Look in: | Project Files ~ [Fitter: [ All Source
Search: |
Previous Next Pause
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Options ~
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HaxaTb Project -> Project Properties... -> Options -> Default File Encoding

# untitled-1.py (C:\Users\Nick): Default Project: Wing = X
File Edit Source Project Debug Tools Window Help

AT New Project... HZeze P P T o

Open Project...

Help untitled-1.p

Project: Default Project [0 files / 0 dirs] Options ~
< Recent 3

Project
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print('npuse Save Project
Save Project As...

Close Project

Add Existing Directory...

Add Current File Ctrl+Shift+|
Add Existing File...

Add New File

Source Assistant

Remove Selected Entry

Call Stack

Show Current File in Project Tool

L L tions...
Project Properties...

Source Browser

Indentation

SearchinFiles  Search  Stack Data Y Debugl/O  Exceptions PythonShell Messages  OS Commands e

Look in: [ Project Files v lFilten l All Source Files v

No debug process Options ~

Search: [ v

Previous Next Pause Options ~
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Help untitled-1.py g Project: Default Project [0 files / 0 dirs] Options ~
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print('npuset 2222')
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Environment  Debug/Execute ~ Options é
Unicode (UTF-8) utf-8 v| [ 3
® Location of Project File
Project Home Directory &5 g ) x
O Specified Directory: &
Browse... E
Preferred Line Ending Use Preferences Setting v ey 5
Line Ending Policy Ignore Conflicts v g
&
Preferred Indent Style Use Preferences Setting v | | 84y s
S
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Indent Style Policy Ignore Conflicts v @A
Strip Trailing White Space | Use Preferences Setting MK 5
Auto-Reformat Use Preferences Setting v 84 £
S
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Reformatter Use Preferences Setting v | | gl £
Search in Files Search Stack Data Reformatter Run Directory Use Preferences Setting v gy s S
Look |n:J Project Files v |F|Iter: | All Source Files v Apply % Cancel Options ~
Search: [ ;
Previous Next Pause Options ~
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# untitled-1.py: Default Project: Wing

File Edit Source Project Debug Tools Window Help
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Search in Files Search Stack Data Debug I/0 Exceptions Python Shell Messages 0S Commands
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Call Stack  Source Assistant  Project

Source Browser

Indentation

Symbol: None

No symbol at cursor
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